Dell Releases Security Update for PowerProtect Data Manager Fixing 359 Vulnerabilities
Dell has released a comprehensive security update for its data protection solution Dell PowerProtect Data Manager, addressing a total of 359 vulnerabilities across both native code and third-party components.
The company published security advisory DSA-2026-287 on July 14, 2026, classifying the issues as Critical and strongly recommending that customers apply the patches without delay.
Among the six product-specific vulnerabilities, CVE-2026-40712 affects the REST API due to insufficient input validation. Although exploitation requires high privileges, successful attacks can lead to further privilege escalation. A second flaw, CVE-2026-49499, arises from incorrect security token generation and also enables privilege escalation.
According to the Common Vulnerability Scoring System CVSS v3.1, CVE-2026-40712 received a base score of 9.1 while CVE-2026-49499 scored 8.8. The remaining four native vulnerabilities were rated between 6.0 and 7.2.
The update also resolves 353 vulnerabilities in dependent third-party software. These include 130 issues in the Linux kernel as well as flaws in Apache Log4j, Apache Tomcat, Samba, PostgreSQL, OpenSSL, glibc, Vim, and several other libraries.
Dell advises all users to upgrade to PowerProtect Data Manager 20.2.0.0 or later to eliminate the reported risks.
Related articles
Security Week 2644: Active Exploitation of PHP2Shell Vulnerabilities Confirmed
PHP developers released patches for two critical vulnerabilities collectively known as PHP2Shell on October 20, affecting PHP 8.2 through 8.5 as well as older branches. The flaws allow unauthenticated remote code execution on affected servers, which power approximately 70 percent of websites. Despite expectations of immediate exploitation, confirmed attacks with working exploits only began on October 25. CrowdStrike noted technical difficulties in weaponizing the issues in real-world environments. Only one-fifth of top Russian websites had applied the fixes by October 25. Additional incidents included compromised eMudhra certificates, a critical GitLab flaw, and a 16-year-old Broadcom router vulnerability.
Positive Technologies Offers Up to 500,000 Rubles for Bypassing PT Application Firewall
Positive Technologies has expanded its Standoff Bug Bounty program to include rewards for bypassing its web application firewalls. Researchers can earn between 150,000 and 500,000 rubles for demonstrating practical bypasses against PT Application Firewall PRO and PT Application Firewall Cloud. The program targets the core protective mechanisms, including traffic filtering, attack detection rules, and the management layer used by administrators. Submissions must include reproducible attack scenarios that show how malicious requests can pass through undetected, rather than relying on scanner reports or theoretical findings. Reward amounts vary by severity and confirmed business impact, with critical issues in the PRO version paying up to 500,000 rubles. The company plans to use validated findings to strengthen detection rules and improve overall product resilience.
Tailscale SSH Vulnerability Allows Root Access via Unix Socket Redirection
A researcher identified flaws in Tailscale that let an attacker with existing SSH access on one node escalate to root privileges and move laterally across the network. Erica Windisch of Cyberdione Labs demonstrated the issues in lab conditions against Tailscale 1.104.2 and Headscale 0.29.5. The core problem stems from privileged operations performed by the tailscaled process when handling Unix socket redirection, granting an ordinary SSH session access to root-only resources. The researcher used the technique to interact with Docker and run elevated commands, and showed that broad access policies allow automated lateral movement in under a second. Additional issues include denial-of-service conditions and bypasses of certain restrictions. Recommendations include reviewing SSH policies and disabling unnecessary socket redirection, noting that Headscale 0.29.5 lacks an independent way to turn the feature off.
Critical CVE-2026-111497 Out-of-Bounds Write Flaw in Google Brotli Decoder Impacts Broad Range of Environments
A severe vulnerability has been identified in the Google-developed Brotli decoder used for decompressing data in web communications and other applications. The flaw, tracked as CVE-2026-111497, allows out-of-bounds writes when processing specially crafted compressed data, potentially enabling arbitrary code execution, information disclosure, or denial of service. It carries a CVSS v4.0 base score of 9.2 and is rated Critical. Google has released patched versions 1.2.1, 1.1.1, and 1.0.10 of the library. Node.js incorporated the fix in its updates, while Microsoft issued an out-of-band patch for .NET on October 25, 2026, to address the issue. The vulnerability affects any environment relying on the Brotli C implementation for data decompression.