BoletimSec•October 26, 2026•🇵🇹Translated from Portuguese

Critical Code Injection Flaw in Okta Access Gateway Allows Authenticated Command Execution

Okta has published an advisory detailing CVE-2026-115547, a critical code injection vulnerability affecting the administrative console of Okta Access Gateway. The flaw allows an authenticated administrator to execute arbitrary commands on the appliance with the permissions of the gateway service account.

The vulnerability carries a CVSS 3.1 base score of 9.1 and is classified under CWE-94 (Improper Control of Generation of Code) and CWE-20 (Improper Input Validation). It resides in the console’s handling of configuration values submitted in a specific format, bypassing expected input restrictions.

Versions of the Access Gateway appliance prior to 2026.10.2 are affected. Okta states that the issue is resolved in 2026.10.2 and later releases. No mitigation or workaround is available, making immediate patching the only recommended action.

Exploitation requires administrative access to the Access Gateway console. The advisory notes high privileges as a prerequisite and changed scope, indicating potential impact on components beyond the vulnerable appliance itself. No unauthenticated attack vector or authentication bypass is described.

On the same day, Okta released two additional advisories for the product. One addresses authentication source verification (CVE-2026-115546). The second covers PHP execution flaws tracked as CVE-2026-109618 and CVE-2026-109619, the same issues previously confirmed by Palo Alto Networks in PAN-OS.

Okta has not reported any active exploitation, named threat actors, or provided proof-of-concept code. No external researcher is credited for the discovery. Operators are advised to verify installed versions and review administrative console access permissions.

Related articles

Habr•Vulnerabilities & Exploits

Security Week 2644: Active Exploitation of PHP2Shell Vulnerabilities Confirmed

PHP developers released patches for two critical vulnerabilities collectively known as PHP2Shell on October 20, affecting PHP 8.2 through 8.5 as well as older branches. The flaws allow unauthenticated remote code execution on affected servers, which power approximately 70 percent of websites. Despite expectations of immediate exploitation, confirmed attacks with working exploits only began on October 25. CrowdStrike noted technical difficulties in weaponizing the issues in real-world environments. Only one-fifth of top Russian websites had applied the fixes by October 25. Additional incidents included compromised eMudhra certificates, a critical GitLab flaw, and a 16-year-old Broadcom router vulnerability.

AntiMalware•Vulnerabilities & Exploits

Positive Technologies Offers Up to 500,000 Rubles for Bypassing PT Application Firewall

Positive Technologies has expanded its Standoff Bug Bounty program to include rewards for bypassing its web application firewalls. Researchers can earn between 150,000 and 500,000 rubles for demonstrating practical bypasses against PT Application Firewall PRO and PT Application Firewall Cloud. The program targets the core protective mechanisms, including traffic filtering, attack detection rules, and the management layer used by administrators. Submissions must include reproducible attack scenarios that show how malicious requests can pass through undetected, rather than relying on scanner reports or theoretical findings. Reward amounts vary by severity and confirmed business impact, with critical issues in the PRO version paying up to 500,000 rubles. The company plans to use validated findings to strengthen detection rules and improve overall product resilience.

AntiMalware•Vulnerabilities & Exploits

Tailscale SSH Vulnerability Allows Root Access via Unix Socket Redirection

A researcher identified flaws in Tailscale that let an attacker with existing SSH access on one node escalate to root privileges and move laterally across the network. Erica Windisch of Cyberdione Labs demonstrated the issues in lab conditions against Tailscale 1.104.2 and Headscale 0.29.5. The core problem stems from privileged operations performed by the tailscaled process when handling Unix socket redirection, granting an ordinary SSH session access to root-only resources. The researcher used the technique to interact with Docker and run elevated commands, and showed that broad access policies allow automated lateral movement in under a second. Additional issues include denial-of-service conditions and bypasses of certain restrictions. Recommendations include reviewing SSH policies and disabling unnecessary socket redirection, noting that Headscale 0.29.5 lacks an independent way to turn the feature off.

Security NEXT•Vulnerabilities & Exploits

Critical CVE-2026-111497 Out-of-Bounds Write Flaw in Google Brotli Decoder Impacts Broad Range of Environments

A severe vulnerability has been identified in the Google-developed Brotli decoder used for decompressing data in web communications and other applications. The flaw, tracked as CVE-2026-111497, allows out-of-bounds writes when processing specially crafted compressed data, potentially enabling arbitrary code execution, information disclosure, or denial of service. It carries a CVSS v4.0 base score of 9.2 and is rated Critical. Google has released patched versions 1.2.1, 1.1.1, and 1.0.10 of the library. Node.js incorporated the fix in its updates, while Microsoft issued an out-of-band patch for .NET on October 25, 2026, to address the issue. The vulnerability affects any environment relying on the Brotli C implementation for data decompression.