安全客•October 26, 2026•🇨🇳Translated from Chinese

GitLab Discloses 12-Year-Old CVSS 10.0 Vulnerability Enabling Unauthenticated Remote Code Execution

GitLab has disclosed a CVSS 10.0 vulnerability, CVE-2026-110264, that enables unauthenticated remote code execution on self-hosted instances. The flaw has remained present in both Community and Enterprise editions for twelve years, dating back to the platform’s early releases in 2014.

Impact and Exploitation

The maximum CVSS score reflects an extremely low attack threshold: an adversary needs only network access to the GitLab server to execute arbitrary commands. Attackers can download repositories, implant persistent backdoors, perform lateral movement, or deploy ransomware without any authentication.

Comparisons with prior critical issues highlight the severity. The 2021 Log4Shell vulnerability also scored 10.0 but required log interaction, while the 2024 MOVEit Transfer flaw scored 9.8 and needed additional preconditions. In contrast, the GitLab issue needs no special steps beyond reaching the server.

Why the Vulnerability Persisted

GitLab’s extensive codebase, exceeding one million lines and encompassing code hosting, CI/CD pipelines, issue tracking, wikis, and container registries, makes comprehensive auditing difficult. The flaw arises from subtle logic errors across multiple modules rather than an obvious coding mistake, evading routine testing and security reviews.

Resource constraints on open-source projects further limit deep historical code analysis, allowing the defect to survive repeated updates until the October 2026 patch.

Immediate Actions for Administrators

  • Verify the current GitLab version against the advisory and upgrade to the patched release.
  • Examine access logs for suspicious IP addresses, off-hour activity, and unauthorized API calls.
  • Inspect administrator accounts, repository commits, and CI/CD pipelines for signs of compromise.

Self-hosted deployments often contain proprietary source code, configuration files, and secrets, making rapid response essential.

Temporary Mitigations

When immediate upgrades are impractical, organizations should restrict access via firewalls or WAF rules to approved internal or whitelisted IPs, deploy additional process and network monitoring, maintain verified backups, and enforce least-privilege access with mandatory multi-factor authentication for administrators.

Industry Implications

The incident underscores that security in large, long-lived software projects is an ongoing process rather than a one-time task. Regular vulnerability management, continuous code auditing, and timely patch application remain critical responsibilities for any organization running self-hosted GitLab instances.

Related articles

Habr•Vulnerabilities & Exploits

Security Week 2644: Active Exploitation of PHP2Shell Vulnerabilities Confirmed

PHP developers released patches for two critical vulnerabilities collectively known as PHP2Shell on October 20, affecting PHP 8.2 through 8.5 as well as older branches. The flaws allow unauthenticated remote code execution on affected servers, which power approximately 70 percent of websites. Despite expectations of immediate exploitation, confirmed attacks with working exploits only began on October 25. CrowdStrike noted technical difficulties in weaponizing the issues in real-world environments. Only one-fifth of top Russian websites had applied the fixes by October 25. Additional incidents included compromised eMudhra certificates, a critical GitLab flaw, and a 16-year-old Broadcom router vulnerability.

AntiMalware•Vulnerabilities & Exploits

Positive Technologies Offers Up to 500,000 Rubles for Bypassing PT Application Firewall

Positive Technologies has expanded its Standoff Bug Bounty program to include rewards for bypassing its web application firewalls. Researchers can earn between 150,000 and 500,000 rubles for demonstrating practical bypasses against PT Application Firewall PRO and PT Application Firewall Cloud. The program targets the core protective mechanisms, including traffic filtering, attack detection rules, and the management layer used by administrators. Submissions must include reproducible attack scenarios that show how malicious requests can pass through undetected, rather than relying on scanner reports or theoretical findings. Reward amounts vary by severity and confirmed business impact, with critical issues in the PRO version paying up to 500,000 rubles. The company plans to use validated findings to strengthen detection rules and improve overall product resilience.

AntiMalware•Vulnerabilities & Exploits

Tailscale SSH Vulnerability Allows Root Access via Unix Socket Redirection

A researcher identified flaws in Tailscale that let an attacker with existing SSH access on one node escalate to root privileges and move laterally across the network. Erica Windisch of Cyberdione Labs demonstrated the issues in lab conditions against Tailscale 1.104.2 and Headscale 0.29.5. The core problem stems from privileged operations performed by the tailscaled process when handling Unix socket redirection, granting an ordinary SSH session access to root-only resources. The researcher used the technique to interact with Docker and run elevated commands, and showed that broad access policies allow automated lateral movement in under a second. Additional issues include denial-of-service conditions and bypasses of certain restrictions. Recommendations include reviewing SSH policies and disabling unnecessary socket redirection, noting that Headscale 0.29.5 lacks an independent way to turn the feature off.

Security NEXT•Vulnerabilities & Exploits

Critical CVE-2026-111497 Out-of-Bounds Write Flaw in Google Brotli Decoder Impacts Broad Range of Environments

A severe vulnerability has been identified in the Google-developed Brotli decoder used for decompressing data in web communications and other applications. The flaw, tracked as CVE-2026-111497, allows out-of-bounds writes when processing specially crafted compressed data, potentially enabling arbitrary code execution, information disclosure, or denial of service. It carries a CVSS v4.0 base score of 9.2 and is rated Critical. Google has released patched versions 1.2.1, 1.1.1, and 1.0.10 of the library. Node.js incorporated the fix in its updates, while Microsoft issued an out-of-band patch for .NET on October 25, 2026, to address the issue. The vulnerability affects any environment relying on the Brotli C implementation for data decompression.