安全客•October 26, 2026•🇨🇳Translated from Chinese

Google Brotli Decoder Vulnerability CVE-2026-111497 Enables Remote Code Execution in Node.js, Python, Bun and Envoy

Google Brotli decoder has been found to contain a serious memory corruption vulnerability tracked as CVE-2026-111497. The flaw impacts Node.js, Python, Bun, Envoy and any other software that embeds the official Google Brotli implementation.

What is Brotli and why the impact is so broad

Brotli is a compression format developed by Google and now used for the majority of web traffic to reduce bandwidth and improve page-load times. Because it is part of the modern web standard, virtually every major web server, CDN and proxy relies on the same upstream decoder code. Node.js ships Brotli support natively, Python provides the brotli and brotlicffi packages, the Bun JavaScript runtime includes it by default, and the Envoy cloud-native proxy uses it when Brotli decompression is enabled.

The vulnerability is an Out-of-Bounds Write. An attacker who supplies a malicious Brotli-compressed payload can cause the decoder to write beyond allocated buffers, corrupting adjacent memory. Possible outcomes include denial of service, sensitive data leakage and, most critically, remote code execution.

Node2Shell: Imperva proves RCE on official Node.js builds

Researchers at Imperva successfully weaponized the flaw on unmodified Node.js 24.22.0 (Linux arm64). They named the technique Node2Shell. The exploit works by feeding specially crafted Brotli data to functions such as zlib.brotliDecompress. Although reliability is not 100 percent and multiple attempts may be required, the attack succeeds on a stock release without any debugging symbols or weakened mitigations.

The same payload is blocked on the patched Node.js 24.22.1 release, confirming that the fix is effective. Earlier public proofs-of-concept only worked on deliberately weakened test builds; this demonstration on production binaries significantly raises the risk profile.

Affected software and remediation guidance

  • Node.js 22.x below 22.23.4, 24.x below 24.22.1, 26.x below 26.12.1
  • Python brotli and brotlicffi packages (all versions)
  • Bun all releases that include the built-in Brotli decoder
  • Envoy any deployment with Brotli decompression filters enabled

Administrators should immediately upgrade Node.js to the fixed releases listed above and restart all processes. Python users must wait for updated brotli packages or implement temporary input-size validation. Bun and Envoy users should monitor official channels for patches and consider disabling Brotli decompression until fixes are available.

Supply-chain lessons

The incident once again illustrates how a single upstream library can expose an entire ecosystem. Similar patterns were observed with Log4Shell and the xz-utils backdoor. Organizations are advised to maintain software bill-of-materials (SBOM) records, enable automated dependency updates via tools such as Dependabot, and apply defense-in-depth controls around any decompression routines.

Related articles

Habr•Vulnerabilities & Exploits

Security Week 2644: Active Exploitation of PHP2Shell Vulnerabilities Confirmed

PHP developers released patches for two critical vulnerabilities collectively known as PHP2Shell on October 20, affecting PHP 8.2 through 8.5 as well as older branches. The flaws allow unauthenticated remote code execution on affected servers, which power approximately 70 percent of websites. Despite expectations of immediate exploitation, confirmed attacks with working exploits only began on October 25. CrowdStrike noted technical difficulties in weaponizing the issues in real-world environments. Only one-fifth of top Russian websites had applied the fixes by October 25. Additional incidents included compromised eMudhra certificates, a critical GitLab flaw, and a 16-year-old Broadcom router vulnerability.

AntiMalware•Vulnerabilities & Exploits

Positive Technologies Offers Up to 500,000 Rubles for Bypassing PT Application Firewall

Positive Technologies has expanded its Standoff Bug Bounty program to include rewards for bypassing its web application firewalls. Researchers can earn between 150,000 and 500,000 rubles for demonstrating practical bypasses against PT Application Firewall PRO and PT Application Firewall Cloud. The program targets the core protective mechanisms, including traffic filtering, attack detection rules, and the management layer used by administrators. Submissions must include reproducible attack scenarios that show how malicious requests can pass through undetected, rather than relying on scanner reports or theoretical findings. Reward amounts vary by severity and confirmed business impact, with critical issues in the PRO version paying up to 500,000 rubles. The company plans to use validated findings to strengthen detection rules and improve overall product resilience.

AntiMalware•Vulnerabilities & Exploits

Tailscale SSH Vulnerability Allows Root Access via Unix Socket Redirection

A researcher identified flaws in Tailscale that let an attacker with existing SSH access on one node escalate to root privileges and move laterally across the network. Erica Windisch of Cyberdione Labs demonstrated the issues in lab conditions against Tailscale 1.104.2 and Headscale 0.29.5. The core problem stems from privileged operations performed by the tailscaled process when handling Unix socket redirection, granting an ordinary SSH session access to root-only resources. The researcher used the technique to interact with Docker and run elevated commands, and showed that broad access policies allow automated lateral movement in under a second. Additional issues include denial-of-service conditions and bypasses of certain restrictions. Recommendations include reviewing SSH policies and disabling unnecessary socket redirection, noting that Headscale 0.29.5 lacks an independent way to turn the feature off.

Security NEXT•Vulnerabilities & Exploits

Critical CVE-2026-111497 Out-of-Bounds Write Flaw in Google Brotli Decoder Impacts Broad Range of Environments

A severe vulnerability has been identified in the Google-developed Brotli decoder used for decompressing data in web communications and other applications. The flaw, tracked as CVE-2026-111497, allows out-of-bounds writes when processing specially crafted compressed data, potentially enabling arbitrary code execution, information disclosure, or denial of service. It carries a CVSS v4.0 base score of 9.2 and is rated Critical. Google has released patched versions 1.2.1, 1.1.1, and 1.0.10 of the library. Node.js incorporated the fix in its updates, while Microsoft issued an out-of-band patch for .NET on October 25, 2026, to address the issue. The vulnerability affects any environment relying on the Brotli C implementation for data decompression.