BoletimSec•October 20, 2026•🇵🇹Translated from Portuguese

Cybercriminals Exploit Command Injection Vulnerability in SiteGuard WAF Server Edition

EG Secure Solutions has confirmed that cybercriminals are actively exploiting CVE-2026-106931 in SiteGuard Server Edition, a web application firewall installed directly on the protected server.

The flaw resides in the statistics processing function, which is enabled by default, and permits command injection that grants attackers the ability to run system commands as root on Unix or SYSTEM on Windows.

Security researchers assigned the weakness CWE-78 and scored it 8.5 on CVSS 4.0 and 7.8 on CVSS 3.0. Both ratings describe a local attack vector requiring low privileges and no user interaction.

While the published severity reflects the absence of confirmed remote unauthenticated exploitation, the high-privilege position of an on-server WAF makes successful compromise particularly impactful compared to typical application plugins.

Affected installations include all versions from 2.20 when statistics are active. Apache, Nginx, and IIS editions outside FreeBSD require updates up to 8.00 Update 5, while FreeBSD deployments with Apache or Nginx need 7.00 Update 6. IIS editions between 3.10 and 4.00 Update 4 remain unaffected.

The vendor alerted customers holding direct support contracts on 29 September. JVN published its advisory on 14 October, and JPCERT/CC issued a corresponding alert. Neither organization identified specific threat actors, targeted organizations, attack volume, or exact exploitation methods.

Administrators unable to apply the official update can obtain a patch that replaces the statistics processing files, including for versions whose support has ended. An immediate workaround is to disable the statistics function entirely.

Because the corrective patch removes traces of prior compromise, organizations are advised to first download diagnostic information through the web interface option labeled Information of Diagnosis before applying any fix.

Related articles

Habr•Vulnerabilities & Exploits

Security Week 2644: Active Exploitation of PHP2Shell Vulnerabilities Confirmed

PHP developers released patches for two critical vulnerabilities collectively known as PHP2Shell on October 20, affecting PHP 8.2 through 8.5 as well as older branches. The flaws allow unauthenticated remote code execution on affected servers, which power approximately 70 percent of websites. Despite expectations of immediate exploitation, confirmed attacks with working exploits only began on October 25. CrowdStrike noted technical difficulties in weaponizing the issues in real-world environments. Only one-fifth of top Russian websites had applied the fixes by October 25. Additional incidents included compromised eMudhra certificates, a critical GitLab flaw, and a 16-year-old Broadcom router vulnerability.

AntiMalware•Vulnerabilities & Exploits

Positive Technologies Offers Up to 500,000 Rubles for Bypassing PT Application Firewall

Positive Technologies has expanded its Standoff Bug Bounty program to include rewards for bypassing its web application firewalls. Researchers can earn between 150,000 and 500,000 rubles for demonstrating practical bypasses against PT Application Firewall PRO and PT Application Firewall Cloud. The program targets the core protective mechanisms, including traffic filtering, attack detection rules, and the management layer used by administrators. Submissions must include reproducible attack scenarios that show how malicious requests can pass through undetected, rather than relying on scanner reports or theoretical findings. Reward amounts vary by severity and confirmed business impact, with critical issues in the PRO version paying up to 500,000 rubles. The company plans to use validated findings to strengthen detection rules and improve overall product resilience.

AntiMalware•Vulnerabilities & Exploits

Tailscale SSH Vulnerability Allows Root Access via Unix Socket Redirection

A researcher identified flaws in Tailscale that let an attacker with existing SSH access on one node escalate to root privileges and move laterally across the network. Erica Windisch of Cyberdione Labs demonstrated the issues in lab conditions against Tailscale 1.104.2 and Headscale 0.29.5. The core problem stems from privileged operations performed by the tailscaled process when handling Unix socket redirection, granting an ordinary SSH session access to root-only resources. The researcher used the technique to interact with Docker and run elevated commands, and showed that broad access policies allow automated lateral movement in under a second. Additional issues include denial-of-service conditions and bypasses of certain restrictions. Recommendations include reviewing SSH policies and disabling unnecessary socket redirection, noting that Headscale 0.29.5 lacks an independent way to turn the feature off.

Security NEXT•Vulnerabilities & Exploits

Critical CVE-2026-111497 Out-of-Bounds Write Flaw in Google Brotli Decoder Impacts Broad Range of Environments

A severe vulnerability has been identified in the Google-developed Brotli decoder used for decompressing data in web communications and other applications. The flaw, tracked as CVE-2026-111497, allows out-of-bounds writes when processing specially crafted compressed data, potentially enabling arbitrary code execution, information disclosure, or denial of service. It carries a CVSS v4.0 base score of 9.2 and is rated Critical. Google has released patched versions 1.2.1, 1.1.1, and 1.0.10 of the library. Node.js incorporated the fix in its updates, while Microsoft issued an out-of-band patch for .NET on October 25, 2026, to address the issue. The vulnerability affects any environment relying on the Brotli C implementation for data decompression.