BoletimSec•October 5, 2026•🇵🇹Translated from Portuguese

Dell Patches Six Critical Flaws in Container Storage Modules for Kubernetes

Dell has addressed six vulnerabilities in its Container Storage Modules (CSM), the software suite that connects Dell storage arrays to Kubernetes clusters. Two of the flaws received the highest possible CVSS score of 10.0, enabling remote attackers to gain administrative control without any authentication.

The first critical issue, CVE-2026-63688, stems from missing authentication on the gRPC server within the storage authorization component. An unauthenticated remote attacker can retrieve administrator credentials for every registered storage backend array.

The second 10.0-rated vulnerability, CVE-2026-63692, involves the absence of authentication in both the authorization proxy and the tenant service. Successful exploitation grants complete administrative control over the very service responsible for managing access controls.

A third high-severity flaw, CVE-2026-67269 (CVSS 9.9), results from improper privilege management in the custom resource reconciler. A low-privileged attacker can submit a single malicious resource definition and escalate privileges to root on all nodes, reaching every device in the cluster.

Two additional issues rated 9.8 originate from embedded secrets in the code. CVE-2026-54472 contains hardcoded credentials inside the authorization module, while CVE-2026-61421 exposes the private key used to sign JWT tokens, allowing attackers to forge valid authentication credentials.

The final vulnerability, CVE-2026-67273 (CVSS 9.6), resides in the template engine and permits reading Kubernetes secrets across the entire cluster as well as creating cluster-scoped permissions.

All versions prior to 1.17.0 are affected. The fixes are included in version 1.18.0. No alternative mitigations are available. Dell strongly advises rotating all JWT signing keys after the update, as the previous keys should be treated as publicly known.

Related articles

Habr•Vulnerabilities & Exploits

Security Week 2644: Active Exploitation of PHP2Shell Vulnerabilities Confirmed

PHP developers released patches for two critical vulnerabilities collectively known as PHP2Shell on October 20, affecting PHP 8.2 through 8.5 as well as older branches. The flaws allow unauthenticated remote code execution on affected servers, which power approximately 70 percent of websites. Despite expectations of immediate exploitation, confirmed attacks with working exploits only began on October 25. CrowdStrike noted technical difficulties in weaponizing the issues in real-world environments. Only one-fifth of top Russian websites had applied the fixes by October 25. Additional incidents included compromised eMudhra certificates, a critical GitLab flaw, and a 16-year-old Broadcom router vulnerability.

AntiMalware•Vulnerabilities & Exploits

Positive Technologies Offers Up to 500,000 Rubles for Bypassing PT Application Firewall

Positive Technologies has expanded its Standoff Bug Bounty program to include rewards for bypassing its web application firewalls. Researchers can earn between 150,000 and 500,000 rubles for demonstrating practical bypasses against PT Application Firewall PRO and PT Application Firewall Cloud. The program targets the core protective mechanisms, including traffic filtering, attack detection rules, and the management layer used by administrators. Submissions must include reproducible attack scenarios that show how malicious requests can pass through undetected, rather than relying on scanner reports or theoretical findings. Reward amounts vary by severity and confirmed business impact, with critical issues in the PRO version paying up to 500,000 rubles. The company plans to use validated findings to strengthen detection rules and improve overall product resilience.

AntiMalware•Vulnerabilities & Exploits

Tailscale SSH Vulnerability Allows Root Access via Unix Socket Redirection

A researcher identified flaws in Tailscale that let an attacker with existing SSH access on one node escalate to root privileges and move laterally across the network. Erica Windisch of Cyberdione Labs demonstrated the issues in lab conditions against Tailscale 1.104.2 and Headscale 0.29.5. The core problem stems from privileged operations performed by the tailscaled process when handling Unix socket redirection, granting an ordinary SSH session access to root-only resources. The researcher used the technique to interact with Docker and run elevated commands, and showed that broad access policies allow automated lateral movement in under a second. Additional issues include denial-of-service conditions and bypasses of certain restrictions. Recommendations include reviewing SSH policies and disabling unnecessary socket redirection, noting that Headscale 0.29.5 lacks an independent way to turn the feature off.

Security NEXT•Vulnerabilities & Exploits

Critical CVE-2026-111497 Out-of-Bounds Write Flaw in Google Brotli Decoder Impacts Broad Range of Environments

A severe vulnerability has been identified in the Google-developed Brotli decoder used for decompressing data in web communications and other applications. The flaw, tracked as CVE-2026-111497, allows out-of-bounds writes when processing specially crafted compressed data, potentially enabling arbitrary code execution, information disclosure, or denial of service. It carries a CVSS v4.0 base score of 9.2 and is rated Critical. Google has released patched versions 1.2.1, 1.1.1, and 1.0.10 of the library. Node.js incorporated the fix in its updates, while Microsoft issued an out-of-band patch for .NET on October 25, 2026, to address the issue. The vulnerability affects any environment relying on the Brotli C implementation for data decompression.